1. Wenn du hier im Forum ein neues Thema erstellst, sind schon Punkte aufgeführt die du ausfüllen musst. Das dient im Allgemeinen dazu die notwendigen Informationen direkt mit der Frage bereitzustellen.
    Da in letzter Zeit immer wieder gerne das Formular gelöscht wurde und erst nach 3 Seiten Nachfragen die benötigten Infos für eine Hilfe kommen, werde ich nun jede Fragestellung die nicht einmal annähernd das Formular benutzt, sofort in den Sondermüll schicken.
    Füllt einfach die abgefragte Daten aus und alle können euch viel schneller helfen.
    Information ausblenden

SSL - https

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von UwePeterLudwig, 14. März 2017.

Schlagworte:
  1. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Link? (das man das aber auch immer wieder fragen muss... )
     
  2. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

  3. PaintSplasher

    PaintSplasher Neues Mitglied Lizenzinhaber

    Da im Quelltext noch mindestens 18 Verlinkungen auf http:// laufen, wird es bisher auch nichts mit SSL. Ich glaube
    du hast auch im AdminCP -> Grundeinstellungen des Forums noch kein https als URL eingetragen, kann das sein?
     
    UwePeterLudwig gefällt das.
  4. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Habe ich eben angepasst in den Grundeinstellungen in https://

    Im Quelltext werde ich aber wohl nicht alle anpassen können, oder? z.B. Facebook-Verlinkungen und co.
     
  5. PaintSplasher

    PaintSplasher Neues Mitglied Lizenzinhaber

    Verlinkungen auf externe Seiten sind irrelevant, aber es fängt schon bei deinem Headerbild an

    "http://abload.de/img/panorama-logo-mittelddyxnk.jpg"

    Das solltest du besser auf deinem Webspace speichern und verlinken, und nicht bei einem Bilderdienst hinterlegen. (und dann entweder relativ einbinden oder mit https://)
     
    otto, UwePeterLudwig und V0RT3X gefällt das.
  6. V0RT3X

    V0RT3X Bekanntes Mitglied Lizenzinhaber

    ...
     
  7. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Ja stimmt, das ändere ich noch und dann sind im Quelltext aber noch 2-3 http:// mit meiner Domaine geblieben neben den Facebook, xendach Domains mit http:// :confused:

    Das SSL-Zertifikat hab ich ansonsten für die Domain schon aktiviert.
     
  8. McAtze

    McAtze Innendienst Lizenzinhaber

    Dann setzt du einfach in den Einstellungen Proxy für Bilder und für Links, und schon sind deine http:// Verlinkungen weg ... ;)
     
    UwePeterLudwig gefällt das.
  9. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Ich hab auf der Startseite 7 http:// links bei dir drin:

    1x http://www.facebook.com/2008/fbml
    2x http://data-vocabulary.org/Breadcrumb
    1x http://www.browserchoice.eu/BrowserChoice/browserchoice_de.htm
    1x http://abload.de/img/panorama-logo-mittelddyxnk.jpg (dein Logo)
    1x http://www.xendach.de
    Home - schema.org findest du mehrfach in den Templates und kannst du bedenkenlos auf https:// umstellen

    Kann man in den Templates auch auf https:// unstellen - einfach die Links mal per Hand im Browser per https aufrufen, meist geht das und deshalb kann man die dann ändern. :)
    Das einschalten des Bilderproxys löst die obigen Problem ja eher nicht bzw. nicht alle. ;)

    Und so sucht man sich durchs Forum und stellt so ein Problem nach dem anderem ab. Im Idealfall vor der Umstellung auf https.


    Falls die htaccess Angaben von oben keine Wirkung zeigen - setzt du womöglich nginx ein?
     
    UwePeterLudwig gefällt das.
  10. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Hoffentlich werden die umgewandelt, da sonst vielen Themen Ihre Verweise/ Bilder von abload.de und co. verlieren, oder wie kann man das verstehen? Bin leider noch ein ziemlicher Laie, auch wenn ich stätig dazu lerne. :oops:

    @otto: "nginx", nicht das ich wüsste, ich habe sowas zumindestens nicht bewusst eingerichtet. Ich werde erst einmal die anderen Fehlerquellen versuchen zu beheben und dann noch einmal schauen. Danke schon einmal bis hier. :D
     
  11. McAtze

    McAtze Innendienst Lizenzinhaber

    UwePeterLudwig gefällt das.
  12. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Danke für den Hinweis. Deswegen steht der Begriff in Anführungszeichen. Zurückzwinker.
    Zudem ging es um ein Beispiel wie man sich Inhalte aus rechtlicher Sicht "zu Eigen machen" kann. Ob nun Nutzername in Kombination mit sonstwas ist irrelevant. Darüber befindet ein findiger Anwalt und, wenn es so weit kommen sollte, der Richter.

    @UwePeterLudwig
    Die . htaccess Angaben zeigen natürlich nur Wirkung wenn du deine Seite mit http aufrufst. Dann wird sie permanent auf https umgeleitet.
     
  13. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Ich kenne aus einem befreundetem Forum so einen Fall, wo es um das Wasserzeichen auf einem urheberechtlich geschützten Bild ging. Dort machte es durchaus einen Unterschied, was das Wasserzeichen für eine Aussage darstellt. Aber das kann natürlich jeder für sich halten wie er mag.
    Am Ende des Tages ist ein Wasserzeichen a la "gepostet auf www.domain.de, Nutzername" sogar für den Rechteinhaber von Vorteil, da er so auch bei einem weiter verteilten urheberrechtlich geschützten Bild u.U. viel einfacher zur Quelle der Rechteverletzung finden kann.
    Ergo, es macht die Rechteverletzung zumindest nicht schlimmer.

    Zum Them Copyright / Urheberrecht nur soviel - es wird halt allen halben durcheinander gehauen und das trotz erheblicher Unterschiede in deren Bedeutung. Das wollte ich nur (wieder mal) verdeutlicht haben. Gerade Anfängern ggü. sollte man mMn. daher auch konkret bleiben. Ist ja nun aber auch geklärt. :)

    @UwePeterLudwig
    Die Angaben in der .htaccess zeigen (sollten zeigen) Wirkung wenn die Adresse des Forum mit http://... oder ohne, also so: domain.de aufgerufen wird. Selbst mit Fehlerhaften Inhalten, sollte damit aber in der Adresszeile des Browsers ein https:// zu sehen sein, auch wenn das Schloß nicht grün ist oder ein SSL Fehler vom Browser moniert würde. Eventuell man deine gesamte .htaccess hier posten (ggf. ohne den Teil für den Verzeichnisschutz oder Dateischutz!).
     
  14. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Hm, die Umleitung scheint noch nicht zu funktionieren und es gibt eher neue Probleme. :eek:

    Ich habe die Umleitung wie beschrieben in die ".htaccess" kopiert. Muss diese an eine bestimmte Stelle, bzw. auf eine bestimmte Art vom Rest getrennt werden?
    Ansonsten werde ich mich morgen/ übermorgen ausführlich mit der Beseitigung aller anderen http://-Verweise beschäftigen.
     
  15. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Hm, kann man hier seine Posts nicht mehr bearbeiten?

    Nunja, die Umleitung sollte jetzt schon einmal klappen. Jetzt muss ich nur noch das gelbe Schloss in ein grünes umgewandelt bekommen und alle http-Verlinkungen rausnehmen. Eine schöne Aufgabe fürs Wochenende. :D:p
    Bilder von abload.de lassen sich z.B. auch mit https aufrufen, vielleicht kann ich die Verlinkungen/ Einbettungen ja alle umwandeln... :confused:
     
  16. V0RT3X

    V0RT3X Bekanntes Mitglied Lizenzinhaber

    man kann schon, allerdings nur eine bestimmte zeit lang ;)

    du könntest via mysql query die abload links in allen posts auf einmal ändern und das wochenende ist gerettet :D
     
    UwePeterLudwig gefällt das.
  17. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Das geht bestimmt schneller. :p:D

    Vielleicht kann man ja auch einstellen, dass Bilder nur mit https:// eingebunden werden können?

    Denn sonst wird das grüne Schloss doch immer wieder verloren gehen, oder?
     
  18. McAtze

    McAtze Innendienst Lizenzinhaber

    Ich wiederhole mich nochmals ... ;)

    Nutze die Image-Proxy und Link-Proxy Funktion von Xenforo. :D
     
    otto und UwePeterLudwig gefällt das.
  19. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Ok, habe ich jetzt aktiviert. Jetzt sind alle Bilderlinks mit meiner Domain vorne eingebunden. Wenn die jetzt bei abload z.B. gelöscht werden, bleiben die Bilder dann erhalten aus einer Rücklage auf meinem Server, oder wie?

    Und sollte ich auch einen Geheimschlüssel festlegen? Und wie lange Aufbewahrung empfehlt ihr?
     
  20. UwePeterLudwig

    UwePeterLudwig Aktives Mitglied Lizenzinhaber

    Gut, Titelbild und co. angepasst und nun tatsächlich grünes Schloss, obwohl ich nicht ganz alle http:// aus dem Quelltext raus bekommen hab. :rolleyes:

    Hm, bisher konnte ich immerhin relativ leicht den Link verfolgen und sehen, ob es von abload.de kommt, oder von einem anderen Server. Jetzt sehe ich das natürlich auf Anhieb nicht mehr.
    Hotlinks von Fremden, nicht Bild-abload-Anbietern habe ich eigentlich auch meist entfernt, da das doch auch kritisch ist, oder?
     
    Zuletzt bearbeitet: 25. März 2017
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden