1. Wenn du hier im Forum ein neues Thema erstellst, sind schon Punkte aufgeführt die du ausfüllen musst. Das dient im Allgemeinen dazu die notwendigen Informationen direkt mit der Frage bereitzustellen.
    Da in letzter Zeit immer wieder gerne das Formular gelöscht wurde und erst nach 3 Seiten Nachfragen die benötigten Infos für eine Hilfe kommen, werde ich nun jede Fragestellung die nicht einmal annähernd das Formular benutzt, sofort in den Sondermüll schicken.
    Füllt einfach die abgefragte Daten aus und alle können euch viel schneller helfen.
    Information ausblenden

XF2.1 Update von 2.0 auf 2.1

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von shining, 8. Feb. 2019.

  1. shining

    shining Aktives Mitglied Lizenzinhaber

    Um Dir am besten Helfen zu können, solltest du ein paar Grundlegende Informationen bereithalten.

    Xenforo Version: v2.0.12


    ------------------------------------------------

    Mal wieder eine doofe Frage von mir :D

    Da es aber das erste "größere" Update wird, bin ich mir einfach unsicher, in welcher Reihenfolge man am besten vorgehen muss/sollte.

    Spielt man erst das xenforo update von 2.0 auf die neue 2.1 ein und anschließend die Updates für alle entsprechenden Addons... oder umgekehrt?

    Deaktiviert man die Addons vor dem Update besser alle erst mal oder ist das wurscht?

    :bag:
     
  2. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Also je nach deinem Kenntnisstand ist es wahrscheinlich am besten wenn du alle deaktivierst. Eins meiner Add-ons hat zb den Style zerschossen da die Template Modifikation auf etwas zugegriffen hat wo es nicht sein sollte.
    Ansonsten hatte ich auch mit aktivierten Add-ons keinerlei Probleme mit dem Update und danach eben die Add-ons updaten. Wobei die meisten eh für beide Versionen gehen.
     
    Masetrix und shining gefällt das.
  3. shining

    shining Aktives Mitglied Lizenzinhaber

    Bei uns sind wohl einige der eingesetzen Addons nicht kompatibel da teils eine 2.0 und eine 2.1 Version zur Verfügung steht.

    Mal schauen wann ich mich daran wage und das zu testen .. schiebe es aktuell noch vor mir her weil ich noch keine Lust auf die Arbeit hatte :D
     
  4. argy

    argy Aktives Mitglied Lizenzinhaber

    Ich würd mich hier gern mal mit ranhängen.
    Haben heut versucht ein Update auf die 2.1 zu machen, aber es steht seit über einer Stunde da "Die Seite bekommt gerade ein Update. Bitte versuch es später noch einmal.".
    Zum Glück ist es ein Testsystem was wir scheinbar grad zerschossen haben, die Frage ist aber wie kommt das zu Stande?
    Hatten den Debug-Modus an, aber vor dem Update wieder aus gemacht.

    Gibt es eventuell noch was zu beachten was wir übersehen haben könnten?
     
  5. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Also nachdem du das Updatescript ausgeführt hast blieb es bei dieser Meldung?
     
  6. argy

    argy Aktives Mitglied Lizenzinhaber

    Mein Kollege hat es ausgeführt aber ja, sowohl im Backend als auch im Frontend steht diese Meldung.
     
  7. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Hört sich eher so an als ob der Vorgang nicht abgeschlossen wurde.
    Was sagt er denn wenn du auf /install/index.php?upgrade/ gehst?
     
  8. argy

    argy Aktives Mitglied Lizenzinhaber

    Da bekomm ich eine Fehlermeldung:
    "Line 115: Unknown tag fa encountered."
     
  9. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    direkt beim aufrufen?
    versuch mal folgendes in die config zu schreiben
    $config['checkVersion'] = false;
     
  10. argy

    argy Aktives Mitglied Lizenzinhaber

    Nicht direkt beim Aufruf. Er fängt mit dem Update an und bringt dann einen Fehler.
    Grad eben nochmal versucht und nun schreibt er was von Line 29.
     

    Anhänge:

  11. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Von welcher Version aus updatest du?
     
  12. argy

    argy Aktives Mitglied Lizenzinhaber

    Wie im ersten Screenshot zu sehen von der 2.0.11 aus.
     
  13. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Ja jetzt wo du es sagst sehe ich das auch :p
     
  14. argy

    argy Aktives Mitglied Lizenzinhaber

    Jetzt wirds kurios.
    Mein Kollege hat nochmal alle Daten vom Livesystem auf das Testsystem übertrage und wie haben alle Add-Ons deinstalliert.
    Laut meinem Kollegen wurde das Updatepaket korrekt hinterlegt (kann es schlecht prüfen da er 600km entfernt sitzt und ich nur keinen Zugriff auf den Fileserver habe).
    Allerdings wird beim Versuch das Update mit install/index.php?upgrade/aufzurufen angezeigt, dass es kein verfügbares Update gäbe... :eek:
     
  15. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Ladet ihr die Daten über ein Webinterface hoch oder so?
    Hört sich ein wenig danach an als ob die Daten nicht korrekt auf dem Fileserver liegen.
     
  16. argy

    argy Aktives Mitglied Lizenzinhaber

    Soweit ich weiß macht mein Kollege das direkt auf dem Fileserver.
     
  17. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Vielleicht sollte er sich mal zu wort melden?
     
  18. McAtze

    McAtze Innendienst Lizenzinhaber

    @argy Du hast aber schon den Text in deinem ersten Screenshot gelesen? Die Empfehlung bei der Größe deiner Installation das Upgrade über die Kommandozeile zu machen..

    Ashampoo_Snap_2019.02.15_09h35m58s_001_.png
     
    mph gefällt das.
  19. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Kommt der nicht immer?
     
  20. Kirby

    Kirby Bekanntes Mitglied Lizenzinhaber

    Nein, nur dann wenn das Forum eine entsprechende Größe hat und umfangreichere Aktualisierungsmaßnahmen erforderlich sind.
     
    McAtze gefällt das.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden