XF2.2 AMP für Xenforo

Dieses Thema im Forum "Fragen und Antworten" wurde erstellt von Silmarillion, 30. März 2021.

  1. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Gott bewahre... pfui, nein, nicht doch. :D ;) Ich mach sowas noch von Hand. Menschen sprechen mich an, ich geb ein Angebot raus, und dann wird ein 1-Jahres Vertrag gemacht. So weiß ich 100%ig, mit wem ich Geschäfte mache und brauch auch keinen Man in the middle der auch wieder nur Geld verdienen will.
    Aber ja, ich könnte es mir vorstellen. Ist wie mit der Sichtbarkeit bei Facebook - wirbst du nicht gegen Geld, fällst du massiv in der Sichtbarkeit ab. Ätzend. Nichts ist dort neutral was das angeht.

    Gerüchten zu Folge, sollen Artikel im Xenforo deutlich wertvoller sein als Beiträge. Auch deshalb hab ich das Lexikon in einem der Foren von Beitragstyp auf Artikeltyp umgestellt. Mal sehen wie bzw. ob sich das auswirkt.

    Was die Zugriffe angeht, wünschte ich, Xenforo hätte auch endlich eine eigene Gästestatistik - ich mag kein Google Analytics einsetzen müssen. Aber bei den registrierten ist bei uns die letzten Jahre ein recht konstantes auf und ab mit der Saison zu sehen. Die Fetten Jahre vor Facebook/Instagram usw. sind aber in allen meinen Foren vorbei. Wobei ich auch niemals ein Forum haben will, was inhaltlich wie Facebook daher kommt, wo unter eine Frage x mal die selbe Antwort kommt weil man sich profilieren will und offenbar das geschriebene der anderen nicht lesen mag... ;)
     
  2. Silmarillion

    Silmarillion Bekanntes Mitglied Lizenzinhaber

  3. otto

    otto Bekanntes Mitglied Lizenzinhaber

    nun, schauen wir mal:

    30. Mai 2021 - noch ohne AMP:
    upload_2021-11-9_10-49-18.png

    Juli 2021 mit AMP:
    upload_2021-11-9_11-26-18.png

    Aktuell mit AMP seit 5 Monaten:
    upload_2021-11-9_10-49-56.png
    Im Mittel könnte man einen seichten Anstieg sehen, was aber auffällt bei Seiten ohne AMP sind die Desktop/Mobile Werte meist sehr ähnlich, hier hingegen liegt Mobile sichtbar vorn - allerdings scheint das Forum im Desktop bereich dafür federn gelassen zu haben.
    Xenforo 2.2.x mit AMP

    Zum Vergleich noch ein Forum ohne AMP:
    upload_2021-11-9_10-53-34.png


    Das sind beides natürlich nur Schnappschüsse, interessanter wäre mal ein Blick auf den Verlauf von @Heffalump auf meine beiden Foren. Wäre nett. :)

    Das es nämlich nur Schnappschüsse sind, sieht man hier:
    upload_2021-11-9_10-57-49.png
    Da hat die Sichtbarkeit zu @Masetrix s letztem Screenshot deutlich abgenommen.


    Generell sind bei meinen beiden Foren die letzten Jahre sehr schwer zu vergleichen. Pandemie, Baupreise, Teilzeit, Wetter, Saison, ... da spielt unglaublich vieles rein, was man als Seitenbetreiber nicht im Griff hat.

    Interessant wird mein Winterprojekt - ein altes und bekanntes Forum von Ur-Alt "X-Forum" Software auf Xenforo zu wuppen.
    upload_2021-11-9_11-2-3.png



    Also mal ein Blick aus der Internen Sicht:
    Zetor-Forum.de
    upload_2021-11-9_11-3-59.png
    Nüx... wovor man sich fürchten müsste. :D ;)

    upload_2021-11-9_11-4-49.png
    Deutlich sichtbar die Corona bedingten Peaks - das bleibt abzuwarten wie es sich nun weiterhin verhält.

    upload_2021-11-9_13-29-6.png
    upload_2021-11-9_13-31-28.png


    Hobby-Gartenteich.de
    upload_2021-11-9_11-7-36.png
    Das ist allerdings was wovor man sich fürchten könnte...

    upload_2021-11-9_11-8-55.png
    etwas weniger dramatisch...

    upload_2021-11-9_11-9-35.png
    Deutliche Zunahme der Reaktionen auf Beiträge - die Leute werden einfach fauler. Kann es sein, das die Reaktionen irgendwie nicht in die Benutzeractivität hinein gerechnet werden? Ich mein Aktivität nimmt ab, Beiträge aber halbwegs stabil, Likes zunehmend ... hmm.

    upload_2021-11-9_13-29-49.png
    upload_2021-11-9_13-31-9.png
    Urgs... ich weiß jetzt was ich dieses WE wohl machen werde... OMG (ich hab zuletzt im Juli rein geschaut, da sah es besser aus...
    Grund ist u.a. CLS (durch unsere 3 dynamisch ausgewählten Banner) und wenn das nicht hilft, wäre AMP zu überlegen.


    Hier (Teichforum als auch Zetorworld.com) wäre es nun interessant, AMP mal einzusetzen und zu beobachten wohin die Reise geht.
     
    Zuletzt bearbeitet: 9. Nov. 2021
    mph gefällt das.
  4. otto

    otto Bekanntes Mitglied Lizenzinhaber

    So, seit ein paar Tagen läuft AMP nun auch auf Hobby-Gartenteich.de, es brauchte 3 Tage bis Google davon Wind bekam und nun indexiert er los.
    Ich werde berichten wie sich die Dinge ändern.

    Positiv wäre schon eine Stagnation über den Winter, weil absolut nicht in unserer Saison.
    Überraschend wäre eine sichtbar positive Beeinflussung.

    Wirklich erwarten tu ich wenig, einfach weniger gemecker durch Google erstmal und damit kein abrutschen im Ranking. Wir werden sehen.
     
  5. Masetrix

    Masetrix Bekanntes Mitglied Lizenzinhaber

    Also bei uns kann ich zu AMP nur sagen, dass sich die Zahlen anfänglich, dadurch dass der Mobile style damit (3G) wesentlich schneller laden ließ, verbesserten. Inzwischen hat Google seinem Algorithmus eine Qualitätsbeurteilung von Inhalten, und auch so manch andere Verschlimmbesserung zu seinen Gunsten spendiert, sodass ich hierzu momentan nichts Genaues nicht sagen kann. :)

    Zu @otto kann ich sagen, dass du noch bestimmte "Patches" anwenden solltest, um da einiges zu verbessern.

    1.) Nutze nicht die Cookiemitteilung, die AMP bereitstellt. Häkchen raus...
    2.) Nutze @Kirby 's Schriftartreduzierung auch in AMP.
    Soweit ich weiß musst du dazu im ACP unter "Werkzeuge", nochmal
    "Rebuild Font Awesome subsets" ausführen.

    Dein Werbescript, so es so bleibt, sollte in einem Widget geladen werden, nicht in der XF-Werbeabteilung.
    Da Widgets jedoch keine Usergruppen berücksichtigen kannst du dort Folgendes nutzen..
    (Bitte die Gruppennummern durch die deinen ersetzen.)

    Den Code nicht bei folgenden Benutzergruppen ausführen:
    Code (Text):

    <xf:if is="{{!$xf.visitor.isMemberOf([1,2,3,4])}}">
     Deinen Code hier drin..
    </xf:if>
     
    Ein Häkchen bei "Forenliste: Oberhalb der Forenliste"
    Ein Häkchen bei "Thread-Ansicht: Über Nachrichten"
    setzen etc.

    Dann kannst du das auch noch abhängig von der Auflösung des Gegenübers laden, wenn du das Widget über die extra.less aufrufst...
    Für den MobileStyle:
    Code (Text):
    @media screen and (max-width: @xf-responsiveMedium)
    {
    ....
    }
    Hth...
     
    Zuletzt bearbeitet: 17. Nov. 2021
    otto gefällt das.
  6. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Schau ich mir die Tage mal an - danke für die Tipps.

    Aktuell kämpfe ich noch mit einer AMP gerechten Darstellung der Werbebanner, welche bei uns dynamisch geladen werden... was ein Sackgang und Zeit was man dafür tot schlägt.
    Werbung sehen bei uns ALLE - daher ist das Thema Nutzergruppen beim Widget nicht so dramatisch, denke ich.

    Iframe im Widget... ok, sollte gehen muss aber erstmal das CLS Problem gelöst bekommen, irgendwie stell ich mich da gerade so richtig doof bei an... :(
     
  7. Kirby

    Kirby Bekanntes Mitglied Lizenzinhaber

    Sollte eigentlich nicht erforderlich sein, schaden tut es aber auch nicht :)
     
    otto gefällt das.
  8. otto

    otto Bekanntes Mitglied Lizenzinhaber

    @Masetrix
    Wegen Cookies. du meinst dieses hier:
    upload_2021-11-19_7-52-23.png
    Also nicht Haken raus, sondern Haken rein, oder?

    Done.
     
  9. otto

    otto Bekanntes Mitglied Lizenzinhaber

  10. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Warum ist das eigentlich so? Wäre wenn, dann wohl ein kleiner Design-Bug und sollte bei XF mal moniert werden. Aber mich interessiert erst einmal warum das so ist. :)
     
  11. Kirby

    Kirby Bekanntes Mitglied Lizenzinhaber

    Kenne ich nicht und kann daher leider nichts dazu sagen.

    Meine unmaßgebliche persönliche Meinung: Nicht ausreichend da keine Informationen welche Cookies, Anbieter, Zwecke etc. genau und auch keine Möglichkeit da individuelle Entscheidungen zu treffen.
    Nach Auffassung der belgischen Datenschutzaufsicht: Unzulässig (gilt vmtl. für alle derzeti am Markt vertretenen Consent-Layer Lösungen)

    Wenn Du keinerlei Cookies außer den technisch notwendigen setzt: Ja (weil dann braucht es gar keinen Consent).
    Falls nicht (und das ist immer der Fall wenn Du XF nicht min. bezüglich der Verwendung des Cookie xf_from_search per Add-on oder Patch angepasst hast): Nein (weil der Cooie-Hinweis ist kein Consent, nur ein Hinweis - man kann den ignorieren und Cookies werden dennoch gesetzt).

    Da kann ich gar nichts dazu sagen, denn das ist nochmal komplizierter - denn Du selbst lieferst das gar nicht aus sondern Google.
    Das muss echt ein Jurist auseinandernehmen wie das mit geteilter Zuständigkeit und so ist.
     
  12. Kirby

    Kirby Bekanntes Mitglied Lizenzinhaber

    Why? Gibt eigentlich keinen wirklichen Grund (der mir bekannt wäre)
    Wir setzen Werbung sowohl in als auch außerhalb von Widgets ein, Probleme gibt es da keine.

    Tun sie, muss man nur entsprechend einstellen:
    upload_2021-11-19_12-6-48.png
     
    Zuletzt bearbeitet: 19. Nov. 2021
    otto gefällt das.
  13. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Erster Zwischenstand...
    upload_2021-11-19_18-9-56.png

    Der eine Fehler, ist lang behoben (vor einer Woche) und auch zeitnah zur erneuten Prüfung angemeldet, aber wie man sieht, ist bisher nichts der gleichen seitens Google geschehen. Dafür saugt sich der Google Bot systematisch die AMP Versionen der Seiten...


    Und das sollte sich nach dem Fix von Kirby heute ja auf absehbar auch wieder ins positive verkehren:
    upload_2021-11-19_18-12-47.png
    Übrigens hat der CLS Fehler keinen einzigen meiner Nutzer gestört, aber was tut man nicht alles für Alphabet... ;)
     
    Masetrix gefällt das.
  14. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Es geht voran...
    upload_2021-11-22_12-53-49.png

    Google muss nur fleißig weiter indizieren dann sollte das im Mobile bald auch wieder alles Grün sein. Danke noch mal an Kirby, für die Hilfe.
    Ich hatte ein Google CLS problem, welches kein Nutzerproblem war - aber eben zur Abwertung führte. Das ist nun behoben und AMP ist auch an Bord...

    upload_2021-11-22_12-56-31.png


    ...weiter beobachten.
     
  15. Kirby

    Kirby Bekanntes Mitglied Lizenzinhaber

    Naja, dass sich keiner beschwert hat heißt nicht dass es kein Nutzerproblem war - nur eben nicht so gravierend dass sich User beschwert haben.

    Nervig war das "rumgewackele" schon und hat mit Sicherheit auch zu mehr CPU-Belastung/Akku-Verbrauch geführt - das wird dem 08/15-User aber eher nicht so direkt auffallen.
     
  16. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Ja, sichtbar war es freilich, ich geh einfach mal von mir aus, und ich bin da normal schon eher pingelich - und mich hats nie wirklich gestört. Schön wars natürlich nicht und so wie jetzt ist es viel besser. :D ;)

    Ich werde mir nach und nach weitere solcher Baustellen vor nehmen, aktuell stehen alte Links und verwaiste Links an...
     
  17. Masetrix

    Masetrix Bekanntes Mitglied Lizenzinhaber

    Stimmt, ich bezog mich hier jedoch auf "von Hause aus". ;)
    Muss ich gleich bei mir einsetzen, manchmal sieht man den Wald vor lauter Bäumen nicht... :)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden