1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Um Zugriff auf die Ressourcen sowie auf Teile des Forums zu erhalten, müsst ihr euren XenForo Validation Token an dieser Stelle hinterlegen. Probleme in diesem Umfeld bitte im Forum melden. Danke!
    Information ausblenden

Animierte Avatars - Installation von ImageMagick PECL Erweiterung

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von CabCon, 20. März 2016.

  1. CabCon

    CabCon Neues Mitglied Lizenzinhaber

    Hallo,
    Ich würde gern animiert avatars auf meinem forum auch animiert sehen. Leider kann ich die options welche ich aktivieren muss um animierte bilder zuzulassen nicht aktivieren, da mir die ImageMagick PECL Erweiterung fehlt.
    [​IMG]



    Leider schaffte ich es bis jetzt nicht diese auf meinem server zu installieren. Und weis nicht genau wie diese Installation aussehen soll. Also wäre es super wenn hier jemand dies nachholen könnte.


    Vielen Dank und mit Grüßen,
    CabCon
     
  2. bt012ss

    bt012ss Gast

    Das macht in der Regel dein Provider für dich, danach muß in der php.ini die Erweiterung noch aktiviert werden.
    Hast du nen eigenen Server dann weiß ich es nicht.

    Code:
    php.ini
    
    extension=imagick.so
    
     
    CabCon gefällt das.
  3. CabCon

    CabCon Neues Mitglied Lizenzinhaber

    Danke schön ich werde mein Provider mal anschreiben. Ich habe einen gemieteten Server bei one.com.
     
  4. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Und falls das bloße verfügbar machen von Imagick nicht zum Erfolg führt: xenforo - Animierte GIF Avatare statt "Standbilder" Ich (und viele andere auch!) hatte das gleiche Problem und das trotz installiertem und aktivem Imagick. Mit dem Tipp aus dem Link hatte es dann zum Erfolg geführt. :good2:
     
  5. Robert9

    Robert9 Aktives Mitglied Lizenzinhaber

    PECL ist dazu da, schreibt Andy B, dass man ImageMagick aus einem Script heraus aufrufen kann.
    Ich rufe seit Jahr und Tag convert aus Scripten heraus auf und das war noch nie ein Problem. Hat sich irgendwas geändert, so dass man PECL braucht?
    Hintergrund ist, dass ich das convert von AndyB geändert haben muss.
    Der Hoster erlaubt auf dem Managed Server ImageMagick, aber kein PECL. Und ich habe keine Lust schon wieder (auf eine Root-Server) umziehen zu müssen.