• Wenn du hier im Forum ein neues Thema erstellst, sind schon Punkte aufgeführt die du ausfüllen musst. Das dient im Allgemeinen dazu die notwendigen Informationen direkt mit der Frage bereitzustellen.
    Da in letzter Zeit immer wieder gerne das Formular gelöscht wurde und erst nach 3 Seiten Nachfragen die benötigten Infos für eine Hilfe kommen, werde ich nun jede Fragestellung die nicht einmal annähernd das Formular benutzt, sofort in den Sondermüll schicken.
    Füllt einfach die abgefragte Daten aus und alle können euch viel schneller helfen.

XF2.2 Massive Fehlermeldungen

otto

Die 5k-Labertasche
Lizenzinhaber
Registriert
11. Dez. 2010
Beiträge
5.247
Punkte
448
XF Version
  1. 2.2.15
XF Instanz
Hosting
PHP-Version
8.2.x
MySQL/MariaDB
10.3.x
Provider/Hoster
Strato/Hetzner
Ich bekomme seit heut Mittag etwa, plötzlich innerhalb unter einer Minute jeweils solche Fehlerlog Einträge (260 Seiten davon voll bisher)

1709036552914.png

Code:
ErrorException: {"sort":["_score",{"date":"desc"}],"docvalue_fields":["discussion_id","user","date"],"_source":false,"size":10,"query":{"bool":{"filter":[{"term":{"type":"thread"}},{"term":{"node":5}}],"must_not":[{"exists":{"field":"hidden"}},{"term":{"thread":7529}}],"must":[{"function_score":{"query":{"multi_match":{"type":"most_fields","query":"Zetor 7340 Turbo Economic Bj. 1997","operator":"or","fields":["title","elasticess_title","title.exact^1.5"]}},"functions":[{"exp":{"date":{"origin":1709036192,"decay":0.5,"scale":60480000}}},{"filter":{"term":{"node":5}},"weight":1.4}]}}]}}} src/XF/Error.php:77
Generiert durch: Unbekanntes Benutzerkonto 27.02.2024 um 13:16 Uhr

Code:
#0 src/XF.php(219): XF\Error->logError('{"sort":["_scor...', false)
#1 src/addons/SV/SearchImprovements/XFES/Elasticsearch/Api.php(48): XF::logError('{"sort":["_scor...')
#2 src/addons/XFES/Search/Source/Elasticsearch.php(750): SV\SearchImprovements\XFES\Elasticsearch\Api->search(Array)
#3 src/addons/SV/SearchImprovements/XFES/Search/Source/Elasticsearch.php(298): XFES\Search\Source\Elasticsearch->executeSearch(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), Array, 10)
#4 src/addons/XFES/Search/Source/Elasticsearch.php(145): SV\SearchImprovements\XFES\Search\Source\Elasticsearch->executeSearch(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), Array, 10)
#5 src/XF/Search/Search.php(185): XFES\Search\Source\Elasticsearch->search(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), 10)
#6 src/XF/Search/Search.php(214): XF\Search\Search->XF\Search\{closure}(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), 10)
#7 src/addons/SV/ElasticSearchEssentials/XF/Search/Search.php(45): XF\Search\Search->executeSearch(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), 10, Object(Closure), true)
#8 src/XF/Search/Search.php(180): SV\ElasticSearchEssentials\XF\Search\Search->executeSearch(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), 10, Object(Closure), true)
#9 src/addons/SV/ElasticSearchEssentials/Service/AutoCompleter.php(532): XF\Search\Search->search(Object(SV\ElasticSearchEssentials\XF\Search\Query\KeywordQuery), 10, true)
#10 src/addons/SV/ElasticSearchEssentials/Service/SimilarContentFinder.php(357): SV\ElasticSearchEssentials\Service\AutoCompleter->getResults()
#11 src/addons/SV/ElasticSearchEssentials/Widget/SimilarThreads.php(69): SV\ElasticSearchEssentials\Service\SimilarContentFinder->getSimilarContents()
#12 internal_data/code_cache/widgets/_32_svESE_similar_threads.php(5): SV\ElasticSearchEssentials\Widget\SimilarThreads->render()
#13 src/XF/Template/Templater.php(7729): XF\SubContainer\Widget->{closure}(Object(X0815\ChkTables\XF\Template\Templater), Array, Array)
#14 src/XF/SubContainer/Widget.php(168): XF\Template\Templater->renderWidgetClosure(Object(Closure), Array)
#15 src/XF/Template/Templater.php(1940): XF\SubContainer\Widget->getCompiledWidget(Array, Array)
#16 internal_data/code_cache/templates/l2/s1/public/thread_view.php(1225): XF\Template\Templater->widgetPosition('sv_thread_view_...', Array)
#17 src/XF/Template/Templater.php(1655): XF\Template\Templater->{closure}(Object(X0815\ChkTables\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#18 src/addons/MaZ/AMP/Traits/Templater/XF22.php(52): XF\Template\Templater->renderTemplate('thread_view', Array, true, NULL)
#19 src/XF/Template/Template.php(24): MaZ\AMP\XF\Template\Templater->renderTemplate('public:thread_v...', Array)
#20 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#21 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#22 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#23 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#24 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#25 src/XF/App.php(2487): XF\Mvc\Dispatcher->run()
#26 src/XF.php(524): XF\App->run()
#27 index.php(20): XF::runApp('XF\\Pub\\App')
#28 {main}

PHP:
array(4) {
  ["url"] => string(53) "/themen/zetor-7340-turbo-economic-bj-1997.7529/page-4"
  ["referrer"] => bool(false)
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}


Hunderte dieser Art - im Forum selbst ist nichts negatives beim besuchen der Beiträge zu bemerken.

Ich hab Jahre lang Ruhe vor sowas gehabt und seit 2.2.15 wirds langsam etwas bunt ...
Das AUN Addon hab ich mal testweise deaktiviert, keine Änderung.
Das Keyword-Addon hab ich auch mal deaktiviert testweise, keine Änderung.

Vorallem hab ich seit 4 Tagen nichts an Forum oder Server angefasst oder geändert... Meine Fresse aber auch.:-(
 
Ok, scheint ein Problem mit Xons Search Enhancements Addon zu sein, und da speziell mit der Wichtung. Hab die Wichtung mal komplett abgeschalten und siehe da, keine neuen Fehlermeldungen mehr.

Ich schreib mal Xon an...
 
Edit - dafür hatte ich hier auf Xendach gerade auch den Fehlerteufel zu Gast:
1709036850032.png
Trat beim speichern des vorherigen Beitrages auf, beim zweiten Versuch gings dann...
 
Edit - dafür hatte ich hier auf Xendach gerade auch den Fehlerteufel zu Gast:
Bleib bloß weg du Fehlerteufel.. :p :D

Ok, scheint ein Problem mit Xons Search Enhancements Addon zu sein, und da speziell mit der Wichtung. Hab die Wichtung mal komplett abgeschalten und siehe da, keine neuen Fehlermeldungen mehr.

Ich schreib mal Xon an...
War auch meine erste Vermutung. Das heißt du hast XFES, dann Xon ElasticSearchEssentials und SearchImprovements installiert.
Hast du denn auch die Standard Lib von Xon aktuell (1.19.0)?
 
Ja, erst heut morgen aktualisiert. Das AUN Addon erinnert einen ja zuverlässig dran wenn frische Updates anstehen. :)
 
Zurück
Oben