1. Wenn du hier im Forum ein neues Thema erstellst, sind schon Punkte aufgeführt die du ausfüllen musst. Das dient im Allgemeinen dazu die notwendigen Informationen direkt mit der Frage bereitzustellen.
    Da in letzter Zeit immer wieder gerne das Formular gelöscht wurde und erst nach 3 Seiten Nachfragen die benötigten Infos für eine Hilfe kommen, werde ich nun jede Fragestellung die nicht einmal annähernd das Formular benutzt, sofort in den Sondermüll schicken.
    Füllt einfach die abgefragte Daten aus und alle können euch viel schneller helfen.
    Information ausblenden

XF2.1 Fehlermeldung Add-on Install?

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von Paridus, 20. Mai 2019.

  1. Paridus

    Paridus Mitglied Lizenzinhaber

    Um Dir am besten Helfen zu können, solltest du ein paar Grundlegende Informationen bereithalten.

    Xenforo Version: 2.1.
    PHP Version: 7.0
    MySQL Version: 5.5.5

    Fehlermeldung:
    Code (Text):
         TypeError: Argument 1 passed to XF\Entity\CronEntry::verifyRunRules() must be of the type array, null given, called in /++++++/src/XF/Mvc/Entity/Entity.php on line 768 src/XF/Entity/CronEntry.php:78
    Code (Text):
    #0 src/XF/Mvc/Entity/Entity.php(768): XF\Entity\CronEntry->verifyRunRules(NULL, 'run_rules', 65552, Array)
    #1 src/XF/Mvc/Entity/Entity.php(613): XF\Mvc\Entity\Entity->_verifyValueCustom(NULL, 'run_rules', 65552, Array)
    #2 src/XF/Mvc/Entity/Entity.php(548): XF\Mvc\Entity\Entity->set('run_rules', NULL)
    #3 src/XF/AddOn/DataType/CronEntry.php(69): XF\Mvc\Entity\Entity->__set('run_rules', NULL)
    #4 src/XF/Job/AddOnData.php(106): XF\AddOn\DataType\CronEntry->importAddOnData('Andy/WeeklyDige...', Object(SimpleXMLElement), 0, G)
    #5 src/XF/Job/Manager.php(253): XF\Job\AddOnData->run(G)
    #6 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
    #7 src/XF/Job/Manager.php(79): XF\Job\Manager->runJobEntry(Array, G)
    #8 src/XF/Admin/Controller/Tools.php(139): XF\Job\Manager->runQueue(true, 8)
    #9 src/XF/Mvc/Dispatcher.php(321): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
    #10 src/XF/Mvc/Dispatcher.php(244): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(XF\Admin\Controller\Tools), NULL)
    #11 src/XF/Mvc/Dispatcher.php(100): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(XF\Admin\Controller\Tools), NULL)
    #12 src/XF/Mvc/Dispatcher.php(50): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
    #13 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
    #14 src/XF.php(390): XF\App->run()
    #15 admin.php(13): XF::runApp('XF\\Admin\\App')
    #16 {main}
    Code (Text):
    Status der Anfrage

    array(4) {
      ["url"] => string(24) "/admin.php?tools/run-job"
      ["referrer"] => string(60) "+++++/admin.php?tools/run-job"
      ["_GET"] => array(1) {
        ["tools/run-job"] => string(0) ""
      }
      ["_POST"] => array(3) {
        ["_xfRedirect"] => string(10) "/admin.php"
        ["_xfToken"] => string(8) "********"
        ["only_ids"] => string(0) ""
      }
    }

    Was bedeutet der Fehler und wie kann er behoben werden?
     
  2. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Welches Add-on?
    Was genau machst du?

    Die Infos die du uns gibst sind ein wenig dürftig.
     
    McAtze gefällt das.
  3. Paridus

    Paridus Mitglied Lizenzinhaber

    Es geht um das Plugin Weekly digest 3.0
     
  4. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Danke das du es verlinkt hast, hier wer es sich auch mal ansehen möchte: Weekly digest

    Ich dachte jetzt eher die Fehlermeldung kommt bei der installation eines anderen Add-ons da in der Meldung der Cron von Weeky diggest angegeben ist.


    PS:
    Aber die allgemeinen Informationen wurde noch nicht mehr, wie wäre es wenn du beschreibst was du gemacht hast, hast du andere Add-ons am laufen?
    Sorry aber noch ein mal werde ich nicht nachfragen...
     
  5. Paridus

    Paridus Mitglied Lizenzinhaber

    Naja ich hatte vorher die Forensoftware 1.5 mit dem alten Plugin am laufen. Habe dann das Forum auf 2. 1 gebracht und versucht die neue Version vom Plugin zu installieren und da kommt immer diese Fehlermeldung.
     
  6. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Ich bin raus...
    Ich gehe mal davon aus das ist nicht dein einziges Add-on gewesen?
    Hast du die Add-ons deaktiviert vor dem Update. Hattest du Problem Add-ons installiert das Widget Framework ist z.B. bekannt Probleme zu verursachen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden