1. Wenn du hier im Forum ein neues Thema erstellst, sind schon Punkte aufgeführt die du ausfüllen musst. Das dient im Allgemeinen dazu die notwendigen Informationen direkt mit der Frage bereitzustellen.
    Da in letzter Zeit immer wieder gerne das Formular gelöscht wurde und erst nach 3 Seiten Nachfragen die benötigten Infos für eine Hilfe kommen, werde ich nun jede Fragestellung die nicht einmal annähernd das Formular benutzt, sofort in den Sondermüll schicken.
    Füllt einfach die abgefragte Daten aus und alle können euch viel schneller helfen.
    Information ausblenden

XF2.1 Fehler bei DB Aufruf über phpmyadmin

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von spicer, 20. März 2020.

Schlagworte:
  1. spicer

    spicer Mitglied Lizenzinhaber

    Um Dir am besten Helfen zu können, solltest du ein paar Grundlegende Informationen bereithalten.

    Xenforo Version: 2.1.8

    Installierte AddOns inkl. Version:
    [ITD] Add All Posts & Threads by User in Member Card II 2.1.4
    [SC] Count Robots 2.0.0
    [Sysnative] Improved Member Stats Widgets 1.2.1
    [TH] Attachments Plus 1.0.1 Patch Level 2
    [TH] Donate 1.1.4
    [TH] Holidays 2.0.0 Patch Level 1
    [TH] UI.X 2.1.2 Patch Level 3 [/B][/SIZE]
    [XenConcept] User Activity 2.1.4 Patch Level 4
    [XenGenTr] Hosgeldin paneli 1.1.3
    [XFA] Like Or Reply To View Attachment 1.1.0
    [XTR] Hide Links and Codes 1.0.1
    [XTR] Prevent of Take it Back Reactions or Change Reactions Type 1.0.0
    Birthday calendar 1.3
    Birthday email 1.3
    Birthday thread 2.2
    Chat 2.1.8
    Daily Doodle 2.0.3
    Editor & BB Code Manager 1.2.1 Patch Level 1
    Forum moderators 1.4
    Forum view count 1.0.0a
    Jazzaaf xenAntiVirus 1.0.0
    Math 2.1.1
    Meta tags 1.2
    Register email 3.1
    Show duplicate attachments 1.0
    Similar threads 6.1
    XenForo Redirects for vBulletin 1.1.5


    PHP-Version: 7.2.24-0ubuntu0.18.04.3
    MySQL-Version: 10.1.44 (10.1.44-MariaDB-0ubuntu0.18.04.1)

    Fehlermeldung:
    Code (Text):
    Einige Fehler wurden auf dem Server entdeckt!
    Bitte schauen Sie am unteren Ende dieses Fensters.
    Link zum Forum: www.ltspiceusers.ch
    ------------------------------------------------
    Erläuterung des Fehlers:

    Wenn ich phpmyadmin aufrufe und einen Table öffne, erscheint die genannte Fehlermeldung.
    Ich kann dann "Alle ignorieren" drücken und der Table wird angezeigt.

    Bei manchen Tables bezweifle ich aber, dass die stimmen.
    Wie zBsp xf_attachment
    Da ist das Feld view_count überall auf 0....das kann nicht sein.

    Warum kommt die Fehlermeldung?


    Edit:
    Habe folgenden Artikel gefunden:
    https://devanswers.co/problem-php-7-2-phpmyadmin-warning-in-librariessql-count/
    Das zeigt eigentlich genau mein Problem. Leider hilft das aber auch nicht weiter :(
     

    Anhänge:

    Zuletzt bearbeitet: 20. März 2020
  2. McAtze

    McAtze Innendienst Lizenzinhaber

    Steht doch klar beschrieben was du machen sollst. Der Fehler liegt an einer inkompatibilität mit PHPMyAdmin 4.6 und PHP7.2
    Du kannst Punkt 1 ab arbeiten und die betroffenen Stelle in der /usr/share/phpmyadmin/libraries/sql.lib.php manuell anpassen, oder aber du machst ein Upgrade von PHPMyAdmin auf die aktuelle Version.
     
  3. spicer

    spicer Mitglied Lizenzinhaber

    Klar hab ich das alles ausprobiert (Steht doch klar beschrieben). Leider funzt keine Variante bei mir.
    Habe das mal in diesem Blog angesprochen.
     
  4. McAtze

    McAtze Innendienst Lizenzinhaber

    Hast du mal geschaut im PHPMyAdmin was du für eine Version einsetzt und was für PHP Version?
    Hast du nach der Ausführung auch mal den Server neu gestartet?
     
  5. spicer

    spicer Mitglied Lizenzinhaber

    Versionsinformationen: 4.6.6deb5
    Und ja, Reboot hab ich immer gemacht nach einer Änderung.
     
  6. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Das ist ja ne uralte PHPMyAdmin Version. Aktuell ist 5.0.2 bzw. 4.9.5 müsste die LTS sein.
     
  7. spicer

    spicer Mitglied Lizenzinhaber

    Das ist die offizielle in Ubuntu 18.04 LTS.
    Am 23. April kommt dann 20.04 raus.
     
  8. McAtze

    McAtze Innendienst Lizenzinhaber

    Ubuntu ist ein Betriebssystem basierend auf dem Linux Kernel. PHPMyAdmin hat absolut nix mit Ubuntu zu tun.
     
  9. spicer

    spicer Mitglied Lizenzinhaber

    Arbeite gerade an einem Update von phpmyadmin. Leider funzt das nicht bis jetzt.
     
  10. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    spicer gefällt das.
  11. spicer

    spicer Mitglied Lizenzinhaber

    Problem gelöst.
    sql.lib.php ist in
    /var/www/new/phpmyadmin/libraries
    und nicht in
    /usr/share/phpmyadmin/libraries
    wie im Tutorial beschrieben.
     
  12. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    /var/www/phpmyadmin ist auch nur ein symlink zu /usr/share/phpmyadmin
     
  13. spicer

    spicer Mitglied Lizenzinhaber

    Bei mir nicht. Vllt wegen EHCP force.
    Zudem heisst der Pfad: /var/www/new/phpmyadmin
     
  14. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Wenn das über den Paketmanager arbeitet, dann muss da eig. ein Symlink sein.
     
  15. spicer

    spicer Mitglied Lizenzinhaber

    Nur phpsysinfo ist bei mir ein Symlink.
    Wie gesagt, vermute ich das EHCP force dafür verantwortlich ist.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden