1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Um Zugriff auf die Ressourcen sowie auf Teile des Forums zu erhalten, müsst ihr euren XenForo Validation Token an dieser Stelle hinterlegen. Probleme in diesem Umfeld bitte im Forum melden. Danke!
    Information ausblenden

NGINX + Plesk + PHP-FPM ... Rewrite Optionen für NGINX festlegen

Dieses Thema im Forum "Technik und Co." wurde erstellt von Maestro2k5, 1. Nov. 2014.

  1. DRaver

    DRaver Bekanntes Mitglied

    Ja strange. Und die sprechen die selbe passwd an?
     
  2. Maestro2k5

    Maestro2k5 Bekanntes Mitglied Lizenzinhaber

    Ja, das lüppt, ich dachte auch es stimmt was mit dem hashwert der PWs nicht, aber dat geht ja an den Ordnern.

    Von Plesk direkt sieht es auch schlecht mit Hilfe aus ... ich glaube es wird zeit das ich mein zeug in ein anderes system übernehmen kann, aber nicht die nächsten Tage. An dieser Stelle erstmal vielen Dank für die Tipps.
     
  3. Maestro2k5

    Maestro2k5 Bekanntes Mitglied Lizenzinhaber

  4. DRaver

    DRaver Bekanntes Mitglied

    Theoretisch sicher. In der Praxis? Also ausprobieren würde ich sagen.
     
    Maestro2k5 gefällt das.
  5. Maestro2k5

    Maestro2k5 Bekanntes Mitglied Lizenzinhaber

    so ich habe noch etwas gebastelt dies ist momentan meine Config. Ich muss aber dazu sagen das Plesk schon alleine die domain mit www erzwingt die https umleitung steht unten.

    Code:
    if ($scheme != "https") {
        rewrite ^ https://www.android-port.de$request_uri? permanent;
    }
    
    if (!-e $request_filename){
        rewrite ^(.*)$ /index.php break;
    }
    
    location /msd {
        auth_basic "MSD";
        auth_basic_user_file /pfad/.htpasswd;
    }
    
    location /tools {
        auth_basic "Tools";
        auth_basic_user_file /pfad/android-port.de/.htpasswd;
    }
    
    location /install {
        auth_basic "Installation";
        auth_basic_user_file /pfad/.htpasswd;
    }
    
    location /pfad/android-port.de/ {
        try_files $uri $uri/ /pfad/android-port.de/index.php?$uri&$args;
        index index.php index.html;
    }
    
    location /pfad/android-port.de/internal_data/ {
        internal;
    }
    
    location /pfad/android-port.de/library/ {
        internal;
    }
    
    location ~ \.php$ {
        try_files $uri =404;
        fastcgi_pass    127.0.0.1:9000;
        fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        include         fastcgi_params;
    }
    
    location ~* \.(jpg|jpeg|gif|png|css|js|ico|xml)$ {
        access_log        off; # deaktiviert access_log für diese Dateitypen
        log_not_found     off; # deaktiviert Meldungen im error_log
        add_header Pragma public;
        add_header Cache-Control “public”;
        try_files $uri @fallback;
        expires           30d;
    }
    
    gzip on;
    gzip_proxied any;
    gzip_types text/plain text/css application/json application/javascript application/x-javascript text/xml application/xml application/xml+rss text/javascript;
    gzip_vary on;
    gzip_comp_level 6;
    gzip_buffers 16 8k;
    gzip_http_version 1.1;
    gzip_disable "MSIE [1-6]\.(?!.*SV1)";
    
    pagespeed EnableFilters combine_css;
    pagespeed EnableFilters collapse_whitespace;
    pagespeed EnableFilters make_google_analytics_async;
    pagespeed EnableFilters canonicalize_javascript_libraries;
    pagespeed EnableFilters remove_comments;
    pagespeed EnableFilters rewrite_images;
    pagespeed EnableFilters move_css_above_scripts;
    pagespeed EnableFilters move_css_to_head;
    pagespeed EnableFilters outline_css;
    pagespeed CssOutlineMinBytes 3000;
    
    fastcgi_read_timeout 300;
    
    autoindex off;
     
    Hoffi und DRaver gefällt das.
  6. DRaver

    DRaver Bekanntes Mitglied

    Schon nicht schlecht .

    Meine Location für PHP

    Code:
    location ~ \.php$ {
            fastcgi_pass unix:/var/run/php5-fpm.sock;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include fastcgi_params;
            fastcgi_read_timeout 300;
            fastcgi_send_timeout 180;
            fastcgi_connect_timeout 60;
            fastcgi_ignore_client_abort off;
            fastcgi_intercept_errors on;
    Cachen sieht bei mir so aus:
    Code:
    # Media: images, icons, video, audio, HTC
            location ~* \.(?:jpg|jpeg|gif|png|ico|gz|svg|svgz|mp4|ogg|ogv|webm|htc|woff)$ {
                expires 1M;
                access_log off;
                add_header Cache-Control "public";
        }
      
    # CSS and Javascript
            location ~* \.(?:css|js)$ {
                expires 1y;
                access_log off;
                add_header Cache-Control "public";
        }
    Und für die Bots, die nach den wichtigsten Schwachstellen suchen gibt es das hier:

    Code:
    # Disable direct access of any *.php files in /wp_includes folder
    location ~ ^/wp-includes/.+\.php$ {
       return 444;
    }
    
    # Disable direct access of any *.php in /wp_content folder
    location ~ ^/wp-content/.+\.php$ {
       return 444;
    }
    
    # Disable direct access of any *.php in /plus folder
    location ~ ^/plus/.+\.php$ {
       return 444;
    }
    # Disable direct access of any *.php in /wp-admin folder
    location ~ ^/wp-admin/.+\.php$ {
       return 444;
    }
     
    Hoffi und Maestro2k5 gefällt das.
  7. Hoffi

    Hoffi !important Lizenzinhaber

    Hier hab ich ja noch viel zum spielen. Fein fein... wenn alles klappt, läuft ab nächsten WE das nächste XF auf nginx.
     
    DRaver gefällt das.
  8. Hoffi

    Hoffi !important Lizenzinhaber

    Ich hab mein internal-data ausserhalb des Web-Roots liegen.

    Was muss ich dazu in der Konfig eintragen?
     
  9. Lemminator

    Lemminator Manchmal verpeilt Lizenzinhaber

    bitte @DRaver
    sag mir mal wo ich dass eintragen muss ?? in die cf. oder unter die sites_avabilable
     
  10. Walks

    Walks Neues Mitglied Lizenzinhaber

    Bin Xenforo Einsteiger und vielleicht könnt ihr mir ja helfen: Habe Nginx-Server und habe von /forums auf /forum umgestellt, sowie auf „Freundliche URLs“ umgestellt - nun läuft gar nichts mehr. Bitte um Hilfe :)