1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Um Zugriff auf die Ressourcen sowie auf Teile des Forums zu erhalten, müsst ihr euren XenForo Validation Token an dieser Stelle hinterlegen. Probleme in diesem Umfeld bitte im Forum melden. Danke!
    Information ausblenden

SSL - https

Dieses Thema im Forum "Fehler, Fragen und Antworten" wurde erstellt von UwePeterLudwig, 14. März 2017.

Schlagworte:
  1. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Kann mir vielleicht jemand helfen, wie ich einen forward HTTP->HTTPS aktivieren kann?

    Hab folgendes Zertifikat aktiv: GeoTrust QuickSSL Premium Wildcard
     
  2. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Wenn du eine permanente Weiterleitung von http auf https meinst hilft das hier in der .htaccess:

    Code:
    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
     
    UwePeterLudwig gefällt das.
  3. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Hab gelesen, dass man dabei aufpassen muss, weil es eventuell Probleme mit alten Verlinkungen geben könnte, die dann nicht mehr funktionieren.
    Hat damit jemand Erfahrung?
     
  4. PaintSplasher

    PaintSplasher Neues Mitglied Lizenzinhaber

    Du kannst auch direkt eine URL betiteln, und ich regel es sehr gerne über den Port, was am Ende zum gleichen Ergebnis führt.

    Code:
    RewriteCond %{SERVER_PORT} !=443
    RewriteRule ^(.*)$ https://www.deine-url.de/$1 [R=301,L] 
    Dabei spielt die URL die danach erzeugt wird keine Rolle, es wird lediglich http gegen https ersetzt. Und Google macht das glücklich ;)
     
  5. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Aber die alten Verlinkungen werden doch weitergeleitet. Dafür machen wir das doch. ;-)
     
  6. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Gut, ja meine User wollen ein "grünes Schloss", was aufgrund von gewissen Bildern aber wohl nicht möglich ist und daher ein grünes Schloss angezeigt wird. Dabei baten sie auch um Umleitung auf https generell.

    Dann werde ich dies mal probieren. Thx :)
     
  7. PaintSplasher

    PaintSplasher Neues Mitglied Lizenzinhaber

    Wenn deine Benutzer ein Bild extern einbetten in Themen, und dieses mittels http eingebettet wurde verschwindet allerdings auch das "grüne "Schloss".
     
    MK70 und UwePeterLudwig gefällt das.
  8. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Dafür gibt es die Proxy Funktion in XenForo. Der speichert fremd eingebundene Bilder auf deinem Server damit sie über SSL ausgeliefert werden können.
     
    MK70, UwePeterLudwig und PaintSplasher gefällt das.
  9. PaintSplasher

    PaintSplasher Neues Mitglied Lizenzinhaber

    Prima, auch was gelernt.
     
  10. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Eben, das ist das Problem.

    @Heffalump: und das ist urheberrechtlich unbedenklich? :confused: Bzw. lassen sich Hotlinks doch meist leichter wieder entfernen, oder wie gehst du da vor?

    Ansonsten vielen Dank schon einmal für die Hilfe. Hoffentlich kriege ich das alles hin. :D
     
  11. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Nein, das ist urheberrechtlich genauso bedenklich wie das hotlinking. Als Forenbetreiber haften wir aber erst nach Kenntnisnahme der Rechtsverletzung. Wenn dich also jemand kostenneutral auf eine Rechtsverletzung hinweist kannst du das Bild entfernen.
     
    UwePeterLudwig gefällt das.
  12. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Ok danke. Werden dann auch bereits eingebundene Bilder umgewandelt? Sonst müsste ich dies ja jeweils nachträglich tun, um überall das grüne Schloss zu erhalten, oder?

    p.s.: Gibt es auch nicht kostenneutrale Hinweise auf Rechtsverletzungen und was ist der Unterschied? :confused:
     
  13. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Ja, das nennt sich dann Abmahnung.
     
  14. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Ist dies auch ohne Kenntnisnahme der Rechtsverletzung direkt möglich? (Das Thema interessiert mich immer wieder, da davor wohl jeder Forenbetreiber Angst hat). :oops:
     
    Zuletzt bearbeitet: 19. März 2017
  15. Heffalump

    Heffalump Bekanntes Mitglied Lizenzinhaber

    Angst muss man nur haben wenn man sich falsch verhält. Natürlich kannst du auch direkt abgemahnt werden. Ein urheberrechtlich geschütztes Bild in einer Diskussion in der du fleißig mitmischst z.B. - Da kannst du schlecht behaupten davon nichts gewusst zu haben.
    Als Forenbetreiber kannst du dir durch gewisse Massnahmen auch Bilder "zu eigen machen". Es gibt Addons, die bilden ein Wasserzeichen ab und viele Nutzen es um ein "Copyright" in das Bild zu integrieren. Dann bist du natürlich auch fällig.

    Ansonsten gilt der Grundsatz, dass Forenbetreiber erst nach Kenntnisnahme der Rechtsverletzung haften. Wenn du darauf aufmerksam gemacht wirst kannst du die Verletzung entfernen und teilst das der Gegenseite mit - fertig.
     
    UwePeterLudwig gefällt das.
  16. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Einschränkung: Wenn da dann im Wasserzeichen steht "c www.forum-name.de" dann ist das heutzutage leicht dämlich. Aber man kann mit entsprechendem Add-on ja auch den Namen des Nutzers einblenden lassen, der es hoch geladen hat und damit ist man als Betreiber wiederum nicht direkt der, welcher fällig ist. Man kann es auch kombinieren - aber ohne Copyright, was es in DE ja eh nicht gibt ;), hier nennt man es Urheberrecht. Und den Namen des Forums + den Uploader angeben...

    Generell sollte man seine Mods auf diese Sachen (Urheberrecht) scharf schalten und auch die Nutzer sensibilisieren und ggf. abstrafen wenn einer meint online alles tun zu können. So machen wir das in unseren Foren seit weit über 10 Jahren und 99% der Nutzer haben auch Verständnis dafür. Auf das 1 uneinsichtige % kann man dann getrost ... ;)
     
    UwePeterLudwig gefällt das.
  17. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Ich beteilige mich letzendlich auch gar nicht mehr selber in meinem Forum und Fotos sehe ich am liebsten eigentlich nur eigene Fotos von den Usern in meinem Forum, da alles was nicht eigenes Bildmaterial ist, natürlich direkt kritisch wird, sodass ich die Hotlinks oftmals heraus nehme.

    Aber noch einmal zurück zum eigentlich Thema des Threads...

    Ich überlege die Upload-Funktion wieder zu aktivieren, aber um das grüne Schloss für meine ganze Seite zu erhalten, müsste ich doch dann alle Hotlinks mit Bildern von externen uploader-portalen umwandeln, oder?
    Sobald Fotos hochgeladen werden, muss ich die doch dann ggf. jedes mal vom Server wieder löschen, da ein einfaches Entfernen aus dem Post ja meist nicht reicht...
    Eine Option wäre auch, nur einer gewissen User-Gruppe das Hochladen zu ermöglichen. :rolleyes:
     
  18. otto

    otto Bekanntes Mitglied Lizenzinhaber

    Was hat die Upload-Funktion mit SSL zu tun? Hochgeladene Bilder liegen doch auf deinem Server - also kein Problem für SSL.

    Problematisch für SSL können lediglich per http://... statt https://... verlinkte, eingefügte Bilder werden. Aber doch keine Uploads.
     
  19. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Naja, ich hatte die Upload-Funktion für User deaktiviert, weil dort manche User anfingen Bilder hoch zu laden, die eventuell urheberrechtlich geschützt waren und nicht zum Teilen gedacht waren, sodass meine User die letzte Zeit ihre Bilder eigentlich immer auf abload.de und co. hochgeladen und eingebunden haben.

    Wenn ich jetzt wieder umstelle und eine Umleitung auf https:// einrichte, dann werden die Bilder, die zuvor eingebunden sind, doch nicht umgewandelt (von abload.de und co.), oder doch? Sprich um ein grünes Schloss zu erhalten, müssten diese http:// eingebundenen Bilder doch raus genommen werden, oder nicht?
     
  20. UwePeterLudwig

    UwePeterLudwig Mitglied Lizenzinhaber

    Hm, hat für mich nichts sichtbar geändert. :confused: