1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Um Zugriff auf die Ressourcen sowie auf Teile des Forums zu erhalten, müsst ihr euren XenForo Validation Token an dieser Stelle hinterlegen. Probleme in diesem Umfeld bitte im Forum melden. Danke!
    Information ausblenden

datei upload nginx ?

Dieses Thema im Forum "Technik und Co." wurde erstellt von sparkoon, 29. Dez. 2016.

  1. sparkoon

    sparkoon Mitglied Lizenzinhaber

    hello

    ich habe folgende probleme mit dem datei upload auf dem server. der sperrt bei ca. 120 mb ab.
    ich habe die php etc angepasst nur bekomme ich ein "413 REQUEST ENTITY TOO LARGE"
    ich habe es in der nginx mal geändert aber dann habe ich das problem wenn ich es unter {htttp { server }} eintrage das ich die foren nicht mehr aufrufen kann. mache ich es ohne server dann fahren alle foren hoch aber der fehler ist immer noch da.
    ich habe den vhost angepasst und da lief es aufeinmal aber bei dem 2ten upload schrieb mir ein fehler raus und stellte sich scheinbar selber wieder um das ich auf den bekannten fehler wieder kam.
    das problem habe ich bei wbb3 / vb4 / phpatm und auch bei xenforo
    brauchen tue ich es nur für das phpatm aber interessant wäre es trotzdem mal wo man das einstellen kann. ich suche seit mitte des jahres nach einer lösung.

    hat einer zufällig eine lösung parat ?
     
  2. Hoffi

    Hoffi !important Lizenzinhaber

    Ich würde zuerst mal schauen was bei nginx der Parameter
    client_max_body_size sagt, oder Ihn einfügen. Im Server oder Location Kontext, je nach Bedarf.
     
  3. sparkoon

    sparkoon Mitglied Lizenzinhaber

    funzt bei mir irgendwie nicht

    http {
    server
    {
    client_max_body_size 200M;
    }
    }

    dann ohne

    http {

    client_max_body_size 200M;

    }
     
  4. sparkoon

    sparkoon Mitglied Lizenzinhaber

    moin

    ich hänge mal meine datei an die ich so habe und nicht funktioniert.

    wäre nett wenn da einer mal rein schauen kann was darin falsch ist ausser die #

    das habe ich extra ausgeklammert weil es zu problemen kam
     

    Anhänge:

    • nginx.zip
      Dateigröße:
      643 Bytes
      Aufrufe:
      2
  5. Hoffi

    Hoffi !important Lizenzinhaber

    Da ist ja kein Location Teil. Wenn du das im Server änderst, und evtl. in der Location wieder verändert wird, geht das nicht.
    Deine Locations liegen vermitlich im

    /etc/nginx/conf.d/
    oder
    /etc/nginx/conf.d/sites-enabled/

    ordner.
     
  6. sparkoon

    sparkoon Mitglied Lizenzinhaber

    in der conf.d steht nur 2 dateien drin wo eine leer ist.

    include /etc/nginx/plesk.conf.d/server.conf;
    include /etc/nginx/plesk.conf.d/webmails/*.conf;
    include /etc/nginx/plesk.conf.d/vhosts/*.conf;
    include /etc/nginx/plesk.conf.d/forwarding/*.conf;
    include /etc/nginx/plesk.conf.d/wildcards/*.conf;

    hatte mal gelesen das ich die in der vhosts / server.conf mal anpassen muss

    /etc/nginx/plesk.conf.d/ip_default/

    wenn ich die url.conf aufmache steht der eintrag drin. den hatte ich mal geändert und da bekomme ich eine fehlermeldung dann.
    der server hat die datei wegen eintrag fehler. dort steht der eintrag mit client_max_body_size 200M drin.

    hab jetzt erstmal nginx abgeschaltet und dann rennt es aufeinmal ohne probleme der upload. auf den foren konnte ich kein fehler feststellen.
     
  7. Hoffi

    Hoffi !important Lizenzinhaber

    Wir denn ohne httpd Dämon, oder hast du Dual Betrieb mit Apache?

    Zumal, wenn du Plesk hast, sollte man nicht manuell an den conf Dateien rumschrauben.
     
  8. sparkoon

    sparkoon Mitglied Lizenzinhaber

    gute frage

    apache ist im dual betrieb am laufen
     
  9. Hoffi

    Hoffi !important Lizenzinhaber

    Entscheide dich für eines. Nginxg oder Apache. Beides funktioniert nur bedingt.
     
    sparkoon gefällt das.
  10. sparkoon

    sparkoon Mitglied Lizenzinhaber

    ok hatte ich auch somit getan gestern abend und hab den nginx abgeschaltet

    dadurch wurde mein problem behoben. aber interessant finde ich es trotzdem das es so probleme macht bin da eher neugierig wie man es beheben kann.

    deshalb hatte ich meine anfrage mal weiter gestellt.

    bis hierhin sage dir rechtherzlichen dank hoffi